Critical Security Advisory: Juniper & Heartbleed Bug
April 11, 2014
PRODUCT AFFECTED:Various products: Please see the list in the problem section
PROBLEM:The TLS and DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly handle Heartbeat Extension packets, which allows remote attackers to obtain sensitive information (such as private keys, username and passwords, or contents of encrypted traffic) from process memory via crafted packets that trigger a buffer over-read. This issue is also known as The Heartbleed Bug.
Status of different OpenSSL versions:• OpenSSL 1.0.1 through 1.0.1f (inclusive) are vulnerable
• OpenSSL 1.0.1g is NOT vulnerable
• OpenSSL 1.0.0 branch is NOT vulnerable
• OpenSSL 0.9.8 branch is NOT vulnerable
To view all affected products please visit: this web page
Critical Security Advisory: Heartbleed Bug
April 10, 2014
SummaryA critical vulnerability has been discovered in the wild that seriously impacts the security of SSL encryption within the OpenSSL family of software. Due to the popularity of OpenSSL as the primary means of encryption in many different types of platforms, including Windows, Linux and appliances-based web services, this issue impacts a majority of all SSL and TLS encrypted web traffic. There are currently multiple scanning and exploitation efforts active on the Internet. Some high value sites, including the Canada Revenue Agency E-File were taken offline on Wednesday April 9, 2014, as a precaution.
CategorizationVulnerability Name: “Heartbleed”
Discovery Date: April 7, 2014
Exploit Code: April 8, 2014
References: MITRE: CVE-2014-0160, US-CERT: TA14-098A, Juniper: JSA10623,
This vulnerability takes advantage of a flaw in the SSL Heartbeat to read internal memory from affected web servers. This may compromise sensitive data, including usernames, passwords, documents, and private keys for SSL encryption. Using a private SSL key, it would be possible for an attacker to decrypt all past, present and future captured traffic to the web service. Additionally, it increases an attackers ability to impersonate the site.
Affected PlatformsMultiple versions of OpenSSL are vulnerable. All versions of OpenSSL from OpenSSL 1.0.1 through 1.0.1f are vulnerable.
OpenSSL 1.0.1g is NOT vulnerable.
All versions prior to OpenSSL 1.0.1 are NOT vulnerable.
Approximately 70% of all web services use OpenSSL, including most servers running varieties of Linux, or popular web services from Apache or Nginx. As a result, most embedded appliances also run this vulnerable software, including products from Juniper, Cisco, and others. Palo Alto firewalls are not affected.
DetectionProof-of-concept code for this vulnerability and can safely identify and validate the patch status of servers and devices.
RemediationIn order to resolve the issue, updated OpenSSL to non-affected versions. Patch appliances and devices with software updates as they become available. For high-value applications, all SSL certificates should be revoked and replaced with regenerated certificates. Sensitive services should also investigate changing all secret keys and advising any users to change passwords and be aware of other potential intrusion attempts as a result of this issue.
Several IPS vendors, including Palo Alto, Cisco and Juniper have released Intrusion Prevention or Threat Prevention signatures to identify and block these attacks. Palo Alto customers should configure Threat Prevention rules to block “Critical” level threats on relevant security policies to enable this protection.